Light theme not working?

I can’t figure out if it’s my browsers or Light Theme not working?

2 Likes

Could you please share some screenshots? After an update a week ago I did see some issues with the light theme. But after reloading the theme in the admin settings things were fine again. I wonder if this is the same issue. I don’t think so though, because on different systems and browsers the theme is working fine now.

By the way, do you have dark mode enabled on your device? Because the light theme automatically turns dark if that’s enabled. Do you mean that?

Both themes look the same (dark) on my device. I have forum installed on it through Fennec. The system is LineageOS without google services for extra security, so things tend to go awry on it from time to time. What is your setup?

But do you have dark mode enabled on your device? The light theme automatically switches to the dark theme when your device has a system wide dark theme setting enabled.

Turns out that is just the case. I haven’t even noticed I had dark style enabled on my device. :slight_smile:

1 Like

I do have Windows 10 Dark theme enabled, however I will not be disabling night theme on Windows 10 as I’m accustomed to using it, but it shouldn’t affect the websites I visit
Brave by default:


Edge:

Chrome:

So I’m thinking it’s definitely a forum problem, could we get more options for themes?

Ah okay. Well , then it’s expected behavior. The light theme is the default theme. Which respects the system wide defaults set by the user. If someone wants dark mode, then dark mode is offered. Only if someone wants to enforce dark mode, then a manual switch is offered. I want to keep things as simple as possible. Many website nowadays respect the system wide theme settings. So if you want a light theme, then disable the dark mode in your system wide settings :slight_smile: This assists with automatic day and night time scheduling of the dark/light theme as well. Having this as a default suits most users.

1 Like

yeah but the problem is when selecting the light theme; it does not work. :neutral_face:

It does work, but since it’s the default theme I enabled dynamic switching as well. So if you set a system wide dark mode, it respects that setting. More and more websites are doing this as well. It’s da futtahhhh :wink: The dark theme option is for systems that don’t have this system wide dark mode option, otherwise there would be just one theme.

So if you want the light theme, then disable dark mode on your device.

I changed the name to “dynamic theme”, to manage expectations.